URI Online Judge Solution 1212 Primary Arithmetic Using C, Python Programming Language.
Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.
Input
Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.
Output
For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.
Sample Input | Sample Output |
123 456 | No carry operation. |
Solution Using C:
#include<stdio.h>
int main()
{
long x,y,c,ans;
while(1)
{
c = ans = 0;
scanf("%ld%ld",&x,&y);
if(x==0 && y==0)
break;
else
{
while(1)
{
c += (x%10)+(y%10);
if(c>9)
{
ans++;
c=1;
}
else
c=0;
x = x/10;
y = y/10;
if(x==0 && y==0)
break;
}
}
if(ans == 0)
printf("No carry operation.\n");
else if(ans==1)
printf("1 carry operation.\n");
else
printf("%ld carry operations.\n", ans);
}
return 0;
}
Comments
Post a Comment