URI Online Judge Solution 1064 Positives and Average using C Programming Language.
Read 6 values that can be floating point numbers. After, print how many of them were positive. In the next line, print the average of all positive values typed, with one digit after the decimal point.
Input
The input consist in 6 numbers that can be integer or floating point values. At least one number will be positive.
Output
The first output value is the amount of positive numbers. The next line should show the average of the positive values typed.
Input Sample | Output Sample |
7
-5 6 -3.4 4.6 12 |
4 valores positivos
7.4 |
Solution using C :
#include <stdio.h>
int main() {
int i,c=0;
float n[6],t=0;
for(i=0; i<6; i++)
{
scanf("%f",&n[i]);
if(n[i]>=0)
{
t += n[i];
c++;
}
}
printf("%d valores positivos\n%.1f\n",c,t/c);
return 0;
}
Comments
Post a Comment