Skip to main content

URI Online Judge Solution 1041 Coordinates of a Point


URI Online Judge Solution 1041 Coordinates of a Point using C, Python Programming Language.

Write an algorithm that reads two floating values (x and y), which should represent the coordinates of a point in a plane. Next, determine which quadrant the point belongs, or if you are over one of the Cartesian axes or the origin (x = y = 0).
If the point is at the origin, write the message "Origem".
If the point is over X axis write "Eixo X", else if the point is over Y axis write "Eixo Y".

Input

The input contains the coordinates of a point.

Output

The output should display the quadrant in which the point is.
Input SampleOutput Sample
4.5 -2.2
Q4
0.1 0.1
Q1
0.0 0.0
Origem

Solution using Python :

X,Y = map(float,input().split())
if X==0.0 and Y==0.0:
    print("Origem")
elif X == 0.0 and Y != 0.0:
    print("Eixo Y")
elif X!=0.0 and Y == 0.0:
    print("Eixo X")
elif X >0.0 and Y > 0.0:
    print("Q1")
elif X>0.0 and Y<0.0:
    print("Q4")
elif X<0.0 and Y>0.0:
    print("Q2")
elif X<0.0 and Y<0.0:
    print("Q3")

Solution using C :

#include <stdio.h>
int main() {
   double x, y;
    scanf("%lf %lf", &x, &y);
    if (x == 0.0 && y == 0.0)
    {
       printf("Origem\n");
    }
    else if (x == 0.0 && y != 0.0)
    {
       printf("Eixo Y\n");
    }
    else if (y == 0.0 && x != 0.0)
    {
        printf("Eixo X\n");
    }
    else if (x > 0.0)
    {
        if (y > 0.0)
        {
           printf("Q1\n");
        }
        else
            printf("Q4\n");
    }
    else if (y > 0.0)
    {
        printf("Q2\n");
    }
    else
        printf("Q3\n");
    return 0;
}

Comments

Popular posts from this blog

URI Problem 1001 Solution Extremely Basic - - URI Online Judge Solution

URI Online Judge Problem 1001 Extremely Basic Solution using C, Python Programming Language. Read 2 variables, named  A  and  B  and make the sum of these two variables, assigning its result to the variable  X . Print  X  as shown below. Print endline after the result otherwise you will get “ Presentation Error ”. Input The input file will contain 2 integer numbers. Output Print the letter  X  (uppercase) with a blank space before and after the equal signal followed by the value of X, according to the following example. Obs.: don't forget the endline after all. Samples Input Samples Output 10 9 X = 19 -10 4 X = -6 15 -7 X = 8 URI 1001 Solution in Python A = int(input()) B = int(input()) X = A + B print("X =",X); URI 1001 Solution in C: #include int main() { int A,B,X; scanf ("%d %d", &A, &B); X=A+B; printf("X = %d\n",X); return 0; }

URI Online Judge Solution 1151 Easy Fibonacci

URI Online Judge Solution 1151 Easy Fibonacci using C Programming Language. he following sequence of numbers 0 1 1 2 3 5 8 13 21 ... is known as the Fibonacci Sequence. Thereafter, each number after the first 2 is equal to the sum of the previous two numbers. Write an algorithm that reads an integer N (N < 46) and that print the first N numbers of this sequence. Input The input file contains an integer number N (0 < N < 46). Output The numbers ​​should be printed on the same line, separated by a blank space. There is no space after the last number. Thanks to Cássio F. Input Sample Output Sample 5 0 1 1 2 3 Solution using C : #include <stdio.h> int main() {     int n,i,n1,n2,t;     scanf("%d",&n);     for(i=1; i<=n; i++)     {         if(i==1)         {         ...

URI Problem 1186 Solution Below the Secundary Diagonal - URI Online Judge Solution

URI Online Judge Solution 1186 Below the Secundary Diagonal   Using C, Python Programming Language. Read an uppercase character that indicates an operation that will be performed in an array M[12][12]. Then, calculate and print the sum or average considering only that numbers that are below of the Secundary diagonal of the array, like shown in the following figure (green area). Input The first line of the input contains a single uppercase character O ('S' or 'M'), indicating the operation Sum or Average (Média in portuguese) to be performed with the elements of the array. Follow 144 floating-point numbers of the array. Output Print the calculated result (sum or average), with one digit after the decimal point. Input Sample Output Sample S 5.0 0.0 -3.5 2.5 4.1 ... 12.6 Solution Using C: #include <stdio.h> int main() {     double a=0.0, M[12][12];     char T[2];     int x,y,c=0;     scanf("%s", &T);     for(x=0;x<=1...