Skip to main content

URI Online Judge Solution 1151 Easy Fibonacci


URI Online Judge Solution 1151 Easy Fibonacci using C Programming Language.
he following sequence of numbers 0 1 1 2 3 5 8 13 21 ... is known as the Fibonacci Sequence. Thereafter, each number after the first 2 is equal to the sum of the previous two numbers. Write an algorithm that reads an integer N (N < 46) and that print the first N numbers of this sequence.

Input

The input file contains an integer number N (0 < N < 46).

Output

The numbers ​​should be printed on the same line, separated by a blank space. There is no space after the last number.
Input SampleOutput Sample
5
0 1 1 2 3

Solution using C :

#include <stdio.h>
int main() {
    int n,i,n1,n2,t;
    scanf("%d",&n);
    for(i=1; i<=n; i++)
    {
        if(i==1)
        {
            n1 = 0;
            printf("%d",n1);
        }
        else if(i==2)
        {
            n2 = 1;
            printf("%d",n2);
        }
        else
        {
            t = n1+n2;
            printf("%d",t);
            n1 = n2;
            n2 = t;
        }
        if(i==n)
            printf("\n");
        else
            printf(" ");
    }
    return 0;
}

Comments

Popular posts from this blog

URI Problem 1001 Solution Extremely Basic - - URI Online Judge Solution

URI Online Judge Problem 1001 Extremely Basic Solution using C, Python Programming Language. Read 2 variables, named  A  and  B  and make the sum of these two variables, assigning its result to the variable  X . Print  X  as shown below. Print endline after the result otherwise you will get “ Presentation Error ”. Input The input file will contain 2 integer numbers. Output Print the letter  X  (uppercase) with a blank space before and after the equal signal followed by the value of X, according to the following example. Obs.: don't forget the endline after all. Samples Input Samples Output 10 9 X = 19 -10 4 X = -6 15 -7 X = 8 URI 1001 Solution in Python A = int(input()) B = int(input()) X = A + B print("X =",X); URI 1001 Solution in C: #include int main() { int A,B,X; scanf ("%d %d", &A, &B); X=A+B; printf("X = %d\n",X); return 0; }

URI Online Judge Solution 1069 Diamonds and Sand

URI Online Judge Solution 1069  Diamonds and Sand using Python Programming Language. John is working in a diamond mine, trying to extract the highest number of diamond "<>". He must exclude all sand particles found "." in this process and after a diamond can be extracted, new diamonds can be formed. If he has as an input. <... << .. >> ....> .... >>>. three diamonds are formed. The first is taken from <..> resulting. <... <> ....> .... >>>. The second diamond is then removed, leaving. <.......> .... >>>. The third diamond is then removed, leaving at the end ..... >>>. without the possibility of extracting new diamonds. Input Read an integer N that is the number of test cases. Then follows N lines each up to 1000 characters, including "<" ,">" and "." Output You must print the amount of diamonds that can be extrated in each test ca...