URI Online Judge Solution 1151 Easy Fibonacci using C Programming Language.
he following sequence of numbers 0 1 1 2 3 5 8 13 21 ... is known as the Fibonacci Sequence. Thereafter, each number after the first 2 is equal to the sum of the previous two numbers. Write an algorithm that reads an integer N (N < 46) and that print the first N numbers of this sequence.
Input
The input file contains an integer number N (0 < N < 46).
Output
The numbers should be printed on the same line, separated by a blank space. There is no space after the last number.
Input Sample | Output Sample |
5
|
0 1 1 2 3
|
Solution using C :
#include <stdio.h>
int main() {
int n,i,n1,n2,t;
scanf("%d",&n);
for(i=1; i<=n; i++)
{
if(i==1)
{
n1 = 0;
printf("%d",n1);
}
else if(i==2)
{
n2 = 1;
printf("%d",n2);
}
else
{
t = n1+n2;
printf("%d",t);
n1 = n2;
n2 = t;
}
if(i==n)
printf("\n");
else
printf(" ");
}
return 0;
}
Comments
Post a Comment