URI Online Judge Solution 1040 Average 3 using C, Python Programming Language.
Read four numbers (N1, N2, N3, N4), which one with 1 digit after the decimal point, corresponding to 4 scores obtained by a student. Calculate the average with weights 2, 3, 4 e 1 respectively, for these 4 scores and print the message "Media: " (Average), followed by the calculated result. If the average was 7.0 or more, print the message "Aluno aprovado." (Approved Student). If the average was less than 5.0, print the message: "Aluno reprovado." (Reproved Student). If the average was between 5.0 and 6.9, including these, the program must print the message "Aluno em exame." (In exam student).
In case of exam, read one more score. Print the message "Nota do exame: " (Exam score) followed by the typed score. Recalculate the average (sum the exam score with the previous calculated average and divide by 2) and print the message “Aluno aprovado.” (Approved student) in case of average 5.0 or more) or "Aluno reprovado." (Reproved student) in case of average 4.9 or less. For these 2 cases (approved or reproved after the exam) print the message "Media final: " (Final average) followed by the final average for this student in the last line.
Input
The input contains four floating point numbers that represent the students' grades.
Output
Print all the answers with one digit after the decimal point.
Input Sample | Output Sample |
2.0 4.0 7.5 8.0
6.4 |
Media: 5.4
Aluno em exame. Nota do exame: 6.4 Aluno aprovado. Media final: 5.9 |
2.0 6.5 4.0 9.0
|
Media: 4.8
Aluno reprovado. |
9.0 4.0 8.5 9.0
|
Media: 7.3
Aluno aprovado. |
URI 1040 Solution in Python:
A,B,C,D = map(float,input().split())
A = (A*2+B*3+C*4+D*1)/10
print("Media: %.1f"%A)
if A>=7.0:
print("Aluno aprovado.")
elif A<5.0:
print("Aluno reprovado.")
elif A>=5.0 and A<7.0:
print("Aluno em exame.")
N = float(input())
print("Nota do exame: %.1f"%N)
N = (A+N)/2
if N>=5.0:
print("Aluno aprovado.")
print("Media final: %.1f"%N)
else:
print("Aluno reprovado.")
print("Media final: %.1f"%N)
URI 1040 Solution in C:
#include <stdio.h>int main() {
double a, b, c, d, e, m;
scanf("%lf %lf %lf %lf", &a, &b, &c, &d);
m = (a * 2 + b * 3 + c * 4 + d) / 10;
printf("Media: %.1f\n", m);
if (m >= 7.0)
{
printf("Aluno aprovado.\n");
}
else if (m >= 5.0)
{
printf("Aluno em exame.\n");
scanf("%lf", &e);
printf("Nota do exame: %.1f\n", e);
if (e + m / 2.0 > 5.0)
{
printf("Aluno aprovado.\n");
}
else
{
printf("Aluno reprovado.\n");
}
printf("Media final: %.1f\n", (e + m) / 2.0);
}
else
{
printf("Aluno reprovado.\n");
}
return 0;
}
Comments
Post a Comment