URI Online Judge Solution 1178 Array Fill III Using C, Python Programming Language.
Read a number X. Put this X at the first position of an array N [100]. In each subsequent position (1 up to 99) put half of the number inserted at the previous position, according to the example below. Print all the vector N.
Input
The input contains a double precision number with four decimal places.
Output
For each position of the array N print "N[i] = Y", where i is the array position and Y is the number stored in that position. Each number of N[...] must be printed with 4 digits after the decimal point.
Input Sample | Output Sample |
200.0000 | N[0] = 200.0000 |
Solution Using C:
#include <stdio.h>
int main() {
int i;
double n;
scanf("%lf",&n);
for(i=0; i<100; i++)
{
printf("N[%d] = %.4lf\n",i,n);
n = n/(float)2;
}
return 0;
}
int main() {
int i;
double n;
scanf("%lf",&n);
for(i=0; i<100; i++)
{
printf("N[%d] = %.4lf\n",i,n);
n = n/(float)2;
}
return 0;
}
Comments
Post a Comment