URI Online Judge Solution 1094 Experiments using C Programming Language.
Maria has just started as graduate student in a medical school and she's needing your help to organize a laboratory experiment which she is responsible about. She wants to know, at the end of the year, how many animals were used in this laboratory and the percentage of each type of animal is used at all.
This laboratory uses in particular three types of animals: frogs, rats and rabbits. To obtain this information, it knows exactly the number of experiments that were performed, the type and quantity of each animal is used in each experiment.
Input
The first line of input contains an integer N indicating the number of test cases that follows. Each test case contains an integer Amount (1 ≤ Amount ≤ 15) which represents the amount of animal used and a character Type ('C', 'R' or 'S'), indicating the type of animal:
- C: Coelho (rabbit in portuguese)
- R: Rato (rat in portuguese)
- S: Sapo (frog in portuguese)
- C: Coelho (rabbit in portuguese)
- R: Rato (rat in portuguese)
- S: Sapo (frog in portuguese)
Output
Print the total of animals used, the total of each type of animal and the percentual of each one in relation of the total of animals used. The percentual must be printed with 2 digits after the decimal point.
Input Sample | Output Sample |
10
10 C 6 R 15 S 5 C 14 R 9 C 6 R 8 S 5 C 14 R |
Total: 92 cobaias
Total de coelhos: 29 Total de ratos: 40 Total de sapos: 23 Percentual de coelhos: 31.52 % Percentual de ratos: 43.48 % Percentual de sapos: 25.00 % |
Solution using C :
#include <stdio.h>
int main() {
int T,sum,frog,rat,rabbits;
sum = frog = rat = rabbits = 0;
scanf("%d",&T);
while(T--)
{
int n;
char a;
scanf("%d %c",&n,&a);
sum += n;
if(a=='C')
rabbits += n;
else if(a=='R')
rat += n;
else if(a=='S')
frog += n;
}
printf("Total: %d cobaias\nTotal de coelhos: %d\nTotal de ratos: %d\nTotal de sapos: %d\n",sum,rabbits,rat,frog);
printf("Percentual de coelhos: %.2f %%\n",((float)(rabbits)/(float)(sum))*100);
printf("Percentual de ratos: %.2f %%\n",((float)(rat)/(float)(sum))*100);
printf("Percentual de sapos: %.2f %%\n",((float)(frog)/(float)(sum))*100);
return 0;
}
Comments
Post a Comment