URI Online Judge Solution 1072 Interval 2 using C Programming Language.
Read an integer N. This N will be the number of integer numbers X that will be read.
Print how many these numbers X are in the interval [10,20] and how many values are out of this interval.
Input
The first line of input is an integer N (N < 10000), that indicates the total number of test cases.
Each case is an integer number X (-107 < X < 107).
Each case is an integer number X (-107 < X < 107).
Output
For each test case, print how many numbers are in and how many values are out of the interval.
Input Sample | Output Sample |
4
14 123 10 -25 |
2 in
2 out |
Solution using C :
#include <stdio.h>
int main() {
int T,num,in,out;
in = out = 0;
scanf("%d",&T);
while(T--)
{
scanf("%d",&num);
if(num>=10 && num <= 20)
in++;
else
out++;
}
printf("%d in\n%d out\n",in,out);
return 0;
}
Really good Beecrowd Solutions This is very good for newb coders. Beecrowd 1072 Interval 2 solution is very confusing but here this exolain in a easy way.
ReplyDelete