URI Online Judge Solution 1043 Triangle using C, Python Programming Language.
Read three point floating values (A, B and C) and verify if is possible to make a triangle with them. If it is possible, calculate the perimeter of the triangle and print the message:
Perimetro = XX.X
If it is not possible, calculate the area of the trapezium which basis A and B and C as height, and print the message:
Area = XX.X
Input
The input file has tree floating point numbers.
Output
Print the result with one digit after the decimal point.
Input Sample | Output Sample |
6.0 4.0 2.0
|
Area = 10.0
|
6.0 4.0 2.1
|
Perimetro = 12.1
|
Solution using Python :
A,B,C = map(float,input().split())
if (A+B)>C and (A+C)>B and (B+C)>A:
A = (A+B+C)
print("Perimetro = %.1f"%A)
else:
A = 0.5*(A+B)*C
print("Area = %.1f"%A)
Solution using C :
#include <stdio.h>
int main() {
float A,B,C;
scanf("%f%f%f",&A,&B,&C);
if(A<(B+C) && B<(C+A) && C < (A+B))
{
printf("Perimetro = %.1f\n", A+B+C);
}
else
{
printf("Area = %.1f\n", C * (A + B) / 2);
}
return 0;
}
Comments
Post a Comment