Skip to main content

URI Online Judge Solution 1024 Encryption


URI Online Judge Solution 1024 Encryption using C Programming Language.

You have been asked to build a simple encryption program. This program should be able to send coded messages without someone been able to read them. The process is very simple. It is divided into two parts.

First, each uppercase or lowercase letter must be shifted three positions to the right, according to the ASCII table: letter 'a' should become letter 'd', letter 'y' must become the character '|' and so on. Second, each line must be reversed. After being reversed, all characters from the half on (truncated) must be moved one position to the left in ASCII. In this case, 'b' becomes 'a' and 'a' becomes '`'.

For example, if the resulting word of the first part is "tesla", the letters "sla" should be moved one position to the left. However, if the resulting word of the first part is "t#$A", the letters "$A" are to be displaced.

Input

The input contains a number of cases of test. The first line of each case of test contains an integer (1 ≤ ≤ 1 * 10⁴), indicating the number of lines the problem should encrypt. The following lines contain characters each (1 ≤ ≤ 1 * 10³).

Output

For each input, you must present the encrypted message.
Input SampleOutput Sample
4
Texto #3
abcABC1
vxpdylY .ph
vv.xwfxo.fd
3# rvzgV
1FECedc
ks. \n{frzx
gi.r{hyz-xx

Solution :

#include <stdio.h>
#include <string.h>
int main()
{
    char str[1000],str1[1000];
    int i,k,j,n,m,l,T;
    scanf("%d",&T);
    getchar();
    while(T--)
    {
        gets(str);
        k = strlen(str);
        for(i=0;i<k;i++)
        {
            if((str[i]>='A' && str[i]<='Z') || (str[i]>='a'&& str[i]<='z'))
                str[i] = str[i] + 3;
        }
        n=0;
        for(j=k-1;j>=0;j--)
        {
            str1[n] = str[j];
            n++;
        }
        str1[n] = '\0';
        l = k/2;
        for(i=l;i<k;i++)
        {
            str1[i] =  str1[i] - 1;
        }
            printf("%s\n",str1);
    }
    return 0;

Comments

Popular posts from this blog

URI Problem 1001 Solution Extremely Basic - - URI Online Judge Solution

URI Online Judge Problem 1001 Extremely Basic Solution using C, Python Programming Language. Read 2 variables, named  A  and  B  and make the sum of these two variables, assigning its result to the variable  X . Print  X  as shown below. Print endline after the result otherwise you will get “ Presentation Error ”. Input The input file will contain 2 integer numbers. Output Print the letter  X  (uppercase) with a blank space before and after the equal signal followed by the value of X, according to the following example. Obs.: don't forget the endline after all. Samples Input Samples Output 10 9 X = 19 -10 4 X = -6 15 -7 X = 8 URI 1001 Solution in Python A = int(input()) B = int(input()) X = A + B print("X =",X); URI 1001 Solution in C: #include int main() { int A,B,X; scanf ("%d %d", &A, &B); X=A+B; printf("X = %d\n",X); return 0; }

URI Online Judge Solution 1151 Easy Fibonacci

URI Online Judge Solution 1151 Easy Fibonacci using C Programming Language. he following sequence of numbers 0 1 1 2 3 5 8 13 21 ... is known as the Fibonacci Sequence. Thereafter, each number after the first 2 is equal to the sum of the previous two numbers. Write an algorithm that reads an integer N (N < 46) and that print the first N numbers of this sequence. Input The input file contains an integer number N (0 < N < 46). Output The numbers ​​should be printed on the same line, separated by a blank space. There is no space after the last number. Thanks to Cássio F. Input Sample Output Sample 5 0 1 1 2 3 Solution using C : #include <stdio.h> int main() {     int n,i,n1,n2,t;     scanf("%d",&n);     for(i=1; i<=n; i++)     {         if(i==1)         {             n1 = 0;             printf("%d",n1);         }         else if(i==2)         {             n2 = 1;             printf("%d",n2);         }

URI Online Judge Solution 1149 Summing Consecutive Integers

URI Online Judge Solution 1149 Summing Consecutive Integers using C Programming Language. Write an algorithm to read a value A and a value N. Print the sum of N numbers from A (inclusive). While N is negative or ZERO, a new N (only N) must be read. All input values are in the same line. Input The input contains only integer values, ​​can be positive or negative. Output The output contains only an integer value. Input Sample Output Sample 3 2 7 3 -1 0 -2 2 7 Solution using C : #include <stdio.h> int main() {     int a,n,s=0;         scanf("%d%d",&a,&n);         while(n<=0)             scanf("%d",&n);         while(n)         {             s += a++;             n--;         }         printf("%d\n",s);     return 0; }