URI Online Judge Problem 1006 Solution Average 2 using Python Programming Language.
Read three values (variables A, B and C), which are the three student's grades. Then, calculate the average, considering that grade A has weight 2, grade B has weight 3 and the grade C has weight 5. Consider that each grade can go from 0 to 10.0, always with one decimal place.
Input
The input file contains 3 values of floating points with one digit after the decimal point.
Output
Print MEDIA(average in Portuguese) according to the following example, with a blank space before and after the equal signal.
Input Samples | Output Samples |
5.0
6.0 7.0 |
MEDIA = 6.3
|
5.0
10.0 10.0 |
MEDIA = 9.0
|
10.0
10.0 5.0 |
MEDIA = 7.5
|
URI 1006 Solution in Python:
A = float(input());
B = float(input());
C = float(input());
MEDIA = (A*2 + B*3 + C*5)/(2+3+5);
print("MEDIA = %.1f"%MEDIA);
Comments
Post a Comment